Welcome, Guest
Please Login or Register.    Lost Password?

Unable to load page in SSL
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: Unable to load page in SSL
#3677
Unable to load page in SSL 5 Years, 2 Months ago Karma: 0
I have a site, server/application/logon.html that uses Go Global.
That site works fine for http, but not https.

In the host options, Security tab when I use transport of TCP and port of 491, everything loads properly. I switch the transport to SSL, the port to 443 and add the SSL certificate. In IIS I bind the certificate to the site and set the SSL settigns to accept client certificates. The server is then rebooted. The page with the https and http protocols won't load anything and responds as if there is nothing there to load. I followed the Cluster Manager Administrator's Guide to setup the certificates and site settings. I'm using Cluster Administrator 4.0.1.10784 and Administrator Guide 4.0.1 *6.28.2011. The host is Server 2008 R2 and the client is Server 2008. Please advise.

It seems I have to choose one of the errors, as stopping one makes the other one start. I'm not sure how to host the site in IIS and run the Application Hosting Service. I believe this is the root cause, but need assistance getting both running.

The Application Hosting Service throws an error: Windows could not start the Application Publishing service on [server]. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to the service-specific error code 3685.

The IIS site throws the error: The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020) when I try to start it. This error generally means that there is contention to a port that you have binding set on, in this case, 491. I put SSL in IIS back to 443 and can start the site in IIS, but the page still behaves as if it doesn't exist when using https, though a message of "Website declined to show this webpage" now appears for http. I added the ?port=491 to the end of the url to try to connect. It pauses for 5 seconds and gives the error "Internet Explorer cannot display the webpage".
CHarrington
Fresh Boarder
Posts: 5
graphgraph
User Offline Click here to see the profile of this user
Last Edit: 2012/09/12 12:44 By CHarrington.
The administrator has disabled public write access.
 
#3678
Re:Unable to load page in SSL 5 Years, 2 Months ago Karma: 0
Upon further testing, Go-Global has been set to SSL transport, port 443 with the generated certificate. IIS has been set with no certificate over port 80 as http. The errors have stopped and I have been able to move forward with using the product. The use of the application is secure, but the site that hosts it isn't. Since I'm having an application run automatically from the logon.html, this isn't a problem so far, but there still needs to be a more elegant and complete solution.
CHarrington
Fresh Boarder
Posts: 5
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#3679
Re:Unable to load page in SSL 5 Years, 2 Months ago Karma: 6
Generally speaking, GO-Global uses only port 491 for both TCP and SSL connections. The SSL encyption (128-bit > 256-bit) is build in to the RXP protocol and enabled via a GO-Global license module & SSL certificate.

For secure web service... You can use port 443, but that port is designated for HTTPS traffic and that is a specific configuration of the web server, not GO-Global. With GO-Global Host, the web server is used purely as a delivery mechanism for client software and related application HTML pages.
Erikt
Administrator
Posts: 591
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl