Welcome, Guest
Please Login or Register.    Lost Password?

1 slow application : how to start troubleshooting
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: 1 slow application : how to start troubleshooting
#3603
1 slow application : how to start troubleshooting 5 Years, 9 Months ago Karma: 0
I have 1 application that is very slow to start. When logging in via RDP on the go-global host, the application starts in about 4 seconds. When launching it through go-global it takes exactly 30 seconds. Always.

the application itself is the print of our ERP package. A print launches a process REPDAEMLAUNCHER.exe, that itselfs starts a process REPDAEMON.exe.
I already places repdaemlauncher.exe in the processes regkey with value 0. I see, if i look at processes via taskmanager that it starts directly repdaemonlauncher.exe, repdaemon.exe and then waits about 10 seconds and starts splwow64.exe. After about 10 to 20 seconds, the result comes to screen (in process repdaemon.exe).

Any tips in order to try to speed up the process?

Regards,
Ignace
IgnaceQ
Junior Boarder
Posts: 25
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#3605
Re: 1 slow application : how to start troubleshooting 5 Years, 9 Months ago Karma: 0
I found out that repdaemon.exe launches quite fast, but it waits for about 15 seconds for splwow64.exe. Once this is running, it takes another 15 seconds to view something...
I changed in the registry processes the value of splwow64.exe to 0 and 2 but both fail. Only the setting of 680 (as it was) gives me the needed result (but after 30 seconds)....


since splwow64.exe is all about printing, i did check that i only use the Universal driver....In my session i have my default printer redirected and i have the preview PDF as default printer in my session.
IgnaceQ
Junior Boarder
Posts: 25
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#3606
Re: 1 slow application : how to start troubleshooting 5 Years, 9 Months ago Karma: 6
You might try to add your application to the process loader options. There is information on how to do this in the Administrator Guide in the section called "Advanced Session Process Configuration". If you're not familiar with this, please work with the GraphOn Support team to add your application and see if that makes a difference in the application startup time.
Erikt
Administrator
Posts: 591
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl