Welcome, Guest
Please Login or Register.    Lost Password?

GGv4 service fails to start with 3698 error
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: GGv4 service fails to start with 3698 error
#3430
GGv4 service fails to start with 3698 error 6 Years, 7 Months ago Karma: 0
I'm running 2008R2 (64bit) with GGv4 64bit version.

2008 SP1 failed to install. I had to remove it to get the server working again. Ever since then, GG has failed to load. The licensing service loads. However when trying to start the GG service, I get a 3698 error. The only thing I can find on this error is:

3698 Invalid SQL syntax - expected password.

Huh?

Any thoughts on how to fix this? I've tried reinstalling with no luck.

From eventvwr:

Faulting application name: cm.exe, version: 4.0.1.10097, time stamp: 0x4d8d63da
Faulting module name: cs4u.dll, version: 4.0.1.10097, time stamp: 0x4d8d6425
Exception code: 0xc0000005
Fault offset: 0x000000000014fcbd
Faulting process id: 0x58c
Faulting application start time: 0x01cbf4f9fc6689d4
Faulting application path: C:\Program Files\GraphOn\GO-Global\Programs\cm.exe
Faulting module path: C:\Program Files\GraphOn\GO-Global\Programs\cs4u.dll
Report Id: 3ab8b324-60ed-11e0-8d44-02215e68c1bb
darkelf921
Fresh Boarder
Posts: 9
graphgraph
User Offline Click here to see the profile of this user
Fitzroy Island
The administrator has disabled public write access.
 
#3431
Re: GGv4 service fails to start with 3698 error 6 Years, 7 Months ago Karma: 0
I've just found a link with a similar problem on 2008R2. The application crashing is Word.

forum.sysinternals.com/application-crash...-rds_topic21453.html
darkelf921
Fresh Boarder
Posts: 9
graphgraph
User Offline Click here to see the profile of this user
Fitzroy Island
The administrator has disabled public write access.
 
#3486
Re: GGv4 service fails to start with 3698 error 6 Years, 5 Months ago Karma: 0
I did running in the same problem.
The OS is Windows Server 2003R2 in German language.
The %ProgramFiless% environment points to C:\Programme.

I've traced the function calls of aps.exe with StraceNtX and found some interesting error:

Tracing command: ["C:\Programme\GraphOn\GO-Global\Programs\aps.exe" -d]
[...]
GObpmData::openFile () caught exception #45
= 0
[T3112] GetLastError(0, 13b48c, 785438c5, 13b48c, ...) = 3
[T3112] TlsGetValue(5, 13b48c, 78543856, 3, ...) = 7c82209e
[T3112] SetLastError(3, 0, 13b48c, 785438c5, ...) = 7ffdf000
[T3112] OutputDebugStringW(13b988, 674fd898, 13c220, 13c220, ...)
when trying to open file C:\Program Files\GraphOn\GO-Global\\Log\Templates/aps_template.html
= 0
[...]

The aps.exe tries to open the log on the wrong path ...
After creating the directory "C:\Program Files\GraphOn\GO-Global\\Log" and copied the contents of the installation directory to it, the service comes up.

Reinstalling the GoGlobal Service in the path "C:\Program Files\GraphOn\GO-Global" fixed that issue on all affected systems.
MatthiasBender
Fresh Boarder
Posts: 1
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl