Welcome, Guest
Please Login or Register.    Lost Password?

problem openning windows
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: problem openning windows
#909
problem openning windows 12 Years, 4 Months ago  
Hi,

Recently I upgraded the Xserver (Xorg), and since then the client stopped lounching application windows. I use windows client and linux server.
These are the relevant lines from the log:

Code:


[18 Jul 17:45:29]: failed to set default font path 'unix/:7100,unix/:7100,/usr/X11R6/lib/X11/fonts/misc/,
/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/,
/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/Type1/'
[18 Jul 17:45:29]: Fatal server error:
[18 Jul 17:45:29]: could not open default font 'fixed' 
[18 Jul 17:45:29]:
[18 Jul 17:45:29]: Deleting connection server



Looks like a font problem, but I can't work it out.

hadar.


The administrator has disabled public write access.
 
#913
Re: problem openning windows 12 Years, 4 Months ago  
It seems like me and Jay (jtt) have the same problem. Can someone help us please?

hadar.


The administrator has disabled public write access.
 
#920
Re: problem openning windows 12 Years, 4 Months ago Karma: 2
Hello Hadar,

What version of Linux are you running? And how did you "upgrade" the X server?

Thanks,
Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#921
Re: problem openning windows 12 Years, 4 Months ago Karma: 0
Hi Troy,

I am running gentoo Linux, and I´m using gentoo´s internal package management system (called portage) for upgrades and installations. Anyhow, I solved the problem (or part of it):

I had a global file that tells gold how to contact the font server, as in the great FAQ you wrote, but I also had some lines in pathes in go-configure that said 'unix/:7100'. Once removed, gold is working again.

The funny thing is, it never happened before I upgraded, and I had the same configuration as above.

hadar.

Note: In the FAQ you wrote 'tcp:/localhost:7100', while for me only 'tcp/localhost:7100' worked.
hadaraz
Fresh Boarder
Posts: 11
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#923
Re: problem openning windows 12 Years, 4 Months ago Karma: 2
I am running gentoo Linux, and I´m using gentoo´s internal package management system (called portage) for upgrades and installations.
Okay. I run Gentoo also so I'm somewhat familiar with portage, and that explains why you might have two choices of X servers. Most distributions don't have that choice, but Gentoo is not like most distributions.

Anyhow, I solved the problem (or part of it):

I had a global file that tells gold how to contact the font server, as in the great FAQ you wrote, but I also had some lines in pathes in go-configure that said 'unix/:7100'. Once removed, gold is working again.

The funny thing is, it never happened before I upgraded, and I had the same configuration as above.

This sounds to me like maybe under the XFree86 server you had a font server running, but under the X.org X server you do not. Thus, GO-Global, once told to use the font server, was having problems since the font server had gone away.

Or, if the font server is still running under the X.org server, perhaps it needs to be reconfigured to accept the GO-Global server's connections? Now that you can start sessions with GO-Global you can try to use xset to add the font server to the fontpath and see what results that gives you.

Note: In the FAQ you wrote 'tcp:/localhost:7100', while for me only 'tcp/localhost:7100' worked.
You're quite right, this was a typo by the person who created that entry; I've corrected it.

Thanks,
Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl