Welcome, Guest
Please Login or Register.    Lost Password?
Go to bottomPage: 1
TOPIC: db Init fails
#798
db Init fails 12 Years, 7 Months ago Karma: 0
Having problems getting a new server install to start on a SunFire 280R running Solaris9. Strange thing is I didn't have a problem with any of the previous servers I've installed and can't find a significat difference in with any system config.

After searching forum I've tried increasing the shared memory and following semaphore params; shmmax, semmni, semmns. Didn't help.

The GoGlobal logfiles do not provide any helpful info. The most verbose debug info I can find is located in the system log:

Apr 28 18:25:14 backup gold[1933]: [ID 633126 user.error] gold: Cybersafe Initialization failed: unable to load library /usr/local/graphon/lib/libcybersafeauth.so: ld.so.1: /usr/local/graphon/bin/gold: fatal: relocation error: file /usr/local/graphon/lib/libcybersafeauth.so: symbol csf_gss_detect_smartcard: referenced symbol not found
Apr 28 18:25:14 backup gold[1933]: [ID 979773 user.error] Database connection failed, retrying:
Apr 28 18:25:19 backup last message repeated 48 times
Apr 28 18:25:20 backup gold[1933]: [ID 990592 user.error] Database connection failed:
Apr 28 18:25:20 backup gold[1933]: [ID 842066 user.crit] startup: cannot open database


Any help is appreciated.

T.I.A.
MikeR.
mrosberg
Fresh Boarder
Posts: 3
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#812
Re: db Init fails 12 Years, 6 Months ago  
I had the same problem before when I had turn on TCP Wrappers on my 280R running Solaris9. I fixed the problem by turning the TCP Wrappers off :cry:. Check your /etc/default/inetd setting for the TCP Wrappers setting.

-- PCT


The administrator has disabled public write access.
 
#813
Re: db Init fails 12 Years, 6 Months ago Karma: 2
Please make sure you're running the most recent released version (v2.1.4) of the server software. We have made changes to try to eliminate these problems. We believe that the problems are caused by a threaded application (gold) using nonblocking I/O (in the PostgreSQL libraries) but we have not been able to reproduce this problem enough to feel entirely confident that it is resolved.

On the other hand, TCP wrappers shouldn't affect this functionality at all. Gold does not support the use of TCP wrappers, and I don't believe that PostgreSQL does, either. So disabling TCP wrappers shouldn't affect this directly.

If you find that it does, it would be interesting to know.

Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl