Welcome, Guest
Please Login or Register.    Lost Password?

Display Problem - GraphOn Server on Sles9 / Wxp Client
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: Display Problem - GraphOn Server on Sles9 / Wxp Client
#764
Display Problem - GraphOn Server on Sles9 / Wxp Client 12 Years, 7 Months ago Karma: 0
Hi out there,
i think i have a connection problem.
The server is running fine on the Sles9.(what a nice rhyme...)
The connection via telnet to port 491 is working from my windows client.
I am using the native graphon client for windows->unix. The client can connect to ther server and i can logon as my testuser. Then my application window appears and i choose xterm with my mouse.
Now, in the lower left corner of my Go Global UX window, appears for a second STANDBY...starting service (xterm) and then STARTED (X:1:11775:3). But nothing happens. The mouse still shows me the clock in the GoGlobal client window. Any ideas?
In the gold.log is no error. Everything is seems to be correct. Have anybody a hint for me?

Have a nice weekend!
Joerg
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#765
Re: Display Problem - GraphOn Server on Sles9 / Wxp Client 12 Years, 7 Months ago Karma: 6
Joerg,

Sounds to me like a possible permission problem. You might check to make sure your license file has proper permissions to launch a session. Also check the Xgo binary to make sure it's set at:

-rws--x--x 1 root root 8079036 Nov 18 06:52 Xgo

If you can log on as a testuser, there should also be a user sessionlog which will provide more diagnostic information. Look in $HOME/.graphon/session-logs/

If all fails, open a ticket with our support team via

http://www.graphon.com/support/unix-support-req.shtml

-Erik
Erikt
Administrator
Posts: 591
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#770
Re: Display Problem - GraphOn Server on Sles9 / Wxp Client 12 Years, 7 Months ago Karma: 0
I have the same problem here with a Suse *sigh* 9.2 installation. The Sessionlog says:

[11 Apr 13:32:58]: AUDIT: Mon Apr 11 13:32:58 2005: 8400 Xgo: [11 Apr 13:32:58]: client 1 rejected from IP 127.0.0.2 port 3789
2
Xlib: connection to "linux:1.0" refused by server
Xlib: Client is not authorized to connect to Server
/usr/local/graphon/bin/gowm-helper: started
/usr/local/graphon/bin/gowm-helper: launching /usr/bin/X11/xterm
[11 Apr 13:32:58]: AUDIT: Mon Apr 11 13:32:58 2005: 8400 Xgo: [11 Apr 13:32:58]: client 1 rejected from IP 127.0.0.2 port 3814
8
Xlib: connection to "linux:1.0" refused by server
Xlib: Client is not authorized to connect to Server
gowm: Can't open display: linux:1. X must be running and $DISPLAY set.

[11 Apr 13:32:58]: waiting for X server to shut down [11 Apr 13:32:58]: Deleting connection server
[11 Apr 13:32:58]: VendorInit.cpp::unregisterInterfaces() : entering.
[11 Apr 13:32:58]: VendorInit.cpp::unregisterInterfaces : unregistering the ClipboardProxy returned 1
[11 Apr 13:32:58]: clipboard classPtr is: 0x82e53d0
[11 Apr 13:32:58]: VendorInit.cpp::unregisterInterfaces() : exiting.


Looks like a permission problem, but not with some file but with connections to the x server. Did i miss something in the manual?
Daniel Meyer
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#771
Re: Display Problem - GraphOn Server on Sles9 / Wxp Client 12 Years, 7 Months ago Karma: 6
Daniel,

Check your login scripts (.login, .profile, etc). Make sure you do not have a DISPLAY variable hardcoded.

Also, we're not sure why SuSE does this, but the solution may be to edit the /etc/hosts file and change it so that the host's own name resolves to 127.0.0.1, instead of 127.0.0.2.

-Erik
Erikt
Administrator
Posts: 591
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#772
Re: Display Problem - GraphOn Server on Sles9 / Wxp Client 12 Years, 7 Months ago Karma: 0
Hi Erikt,

thanks for your reply. Changing the entry in the /etc/hosts file to 127.0.0.1 did the trick. I usually dont work with suse, so i cant answer the question about "why suse does that" either

Danny
Daniel Meyer
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#775
Re: Display Problem - GraphOn Server on Sles9 / Wxp Client 12 Years, 7 Months ago Karma: 0
Hi Erik,
that was the hint i need. It is working now...
Thank you!
Joerg
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl