Welcome, Guest
Please Login or Register.    Lost Password?

go-configure problem
(1 viewing) (1) Guest
Go to bottomPage: 12
TOPIC: go-configure problem
#731
go-configure problem 12 Years, 8 Months ago Karma: 0
Hi,

Recently I tried to change some properties of icons with the go-configure utility, but I always get the same message:

Code:

 The GO-Global UX database could not be opened 


I tryed to change the permissions of the databse, re-install the database, but nothing works. any clues ?

Hadar.
hadaraz
Fresh Boarder
Posts: 11
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#738
Re: go-configure problem 12 Years, 8 Months ago Karma: 0
Anyone has an idea ???!?!??
hadaraz
Fresh Boarder
Posts: 11
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#739
Re: go-configure problem 12 Years, 8 Months ago Karma: 2
Try running GO-Configure like:

Code:

sh -x ${GOGLOBAL_ROOT}/bin/go-configure


This should print the steps executed by the shell wrapper to determine the location of your database. It should look something like this:

Code:

+ default_root=/usr/local/graphon
+ goglobalux_root=/usr/local/graphon
+ goglobalux_lib=/usr/local/graphon/lib:/usr/local/graphon/postgresql/lib
+ '[' -n '' ']'
+ LD_LIBRARY_PATH=/usr/openwin/lib:/usr/local/graphon/lib:/usr/local/graphon/postgresql/lib
+ export LD_LIBRARY_PATH
++ grep '^GOGLOBAL_USER=' /usr/local/graphon/etc/goglobalux
++ cut -d= -f2
++ grep '^GOGLOBAL_DB_PORT=' /usr/local/graphon/etc/goglobalux
++ cut -d= -f2
++ cut -d= -f2
++ grep '^GOGLOBAL_DB_HOST=' /usr/local/graphon/etc/goglobalux
+ args=-dbuser goglobal -dbport 4491 -dbhost localhost
+ exec /usr/local/graphon/lib/exec/config_ui.bin -dbuser goglobal -dbport 4491 -dbhost localhost



The last like will show you what user, host, and port the script is detecting. You should ensure that these are correct for your system.

Otherwise, you might have a name resolution problem (perhaps "localhost" does not resolve), or the database itself may not be responding to connections properly (although if this were the case I'd expect that GO-Global for UNIX would probably not be running at all for you).

Let us know what you find out and we'll see what else we can suggest.

Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#740
Re: go-configure problem 12 Years, 8 Months ago Karma: 0
Hi Troy,

Here is the output. It looks like all these parameters are not recognized on the two last lines.
What should I do?


Code:


$ sh -x /usr/local/graphon/bin/go-configure
+ default_root=/usr/local/graphon
+ goglobalux_root=/usr/local/graphon
+ goglobalux_lib=/usr/local/graphon/lib:/usr/local/graphon/postgresql/lib
+ '[' -n '' ']'
+ LD_LIBRARY_PATH=/usr/openwin/lib:/usr/local/graphon/lib:/usr/local/graphon/postgresql/lib
+ export LD_LIBRARY_PATH
++ grep '^GOGLOBAL_USER=' /usr/local/graphon/etc/goglobalux
++ cut -d= -f2
++ grep '^GOGLOBAL_DB_PORT=' /usr/local/graphon/etc/goglobalux
++ cut -d= -f2
++ grep '^GOGLOBAL_DB_HOST=' /usr/local/graphon/etc/goglobalux
++ cut -d= -f2
+ args=-dbuser  -dbport  -dbhost 
+ exec /usr/local/graphon/lib/exec/config_ui.bin -dbuser -dbport -dbhost



I also have to mention that we are having problems logging in. we have to login & logout about 10 times before we can lounch the icons. Strange, and maybe related to the above problem.

Thanks,
Hadar.
hadaraz
Fresh Boarder
Posts: 11
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#745
Re: go-configure problem 12 Years, 8 Months ago Karma: 0
Hello again,

Now I understarnd what the problem was. Since I work on a different system (gentoo Linux), I changed the 'goglobalux' script to suit the system, and added tabs before the definitions, so 'go-configure' couldn't find them. Removed the tabs, and 'go-configure' is working now.
The problem is, I still need to start & restart the client a few times before I can lounch anything, as I said in the last post. Can you think of any reason for this strange behavior?

Hadar.
hadaraz
Fresh Boarder
Posts: 11
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#746
Re: go-configure problem 12 Years, 8 Months ago Karma: 2
The problem is, I still need to start & restart the client a few times before I can lounch anything, as I said in the last post. Can you think of any reason for this strange behavior?

We have had problems with PostgreSQL not responding to queries in the past, but these problems have mostly been addressed by code implementations. It would probably be helpful to see what is logged in ${GOGLOBAL_ROOT}/etc/gold.log when you log in and do not see the icons.

Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
Go to topPage: 12
Moderators: troy, Andyl