Welcome, Guest
Please Login or Register.    Lost Password?
Go to bottomPage: 1
TOPIC: manual install
#685
manual install 12 Years, 9 Months ago Karma: 0
Hi,

I am trying to install the linux-host-package on unsupported distribution (gentoo). The installer is failing because it is looking for some exectable that is available on redhat only. As I understand it, after the initial installation, the startup script can be tweeked to suit my platform. I was able to manualy unzip the distribution file, but more steps are needed. If it is possible, please publish here the instructions for manual installation.

Thanks in advance,

Hadar Raz.
hadaraz
Fresh Boarder
Posts: 11
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#688
Re: manual install 12 Years, 9 Months ago Karma: 6
Hadar,

Please reference the attached document for the manual installation steps.

-Erik
Erikt
Administrator
Posts: 591
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#691
Re: manual install 12 Years, 8 Months ago Karma: 0
Erik,

Thanks for the fast and efficient reply.

Hadar.
hadaraz
Fresh Boarder
Posts: 11
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#692
install problem 12 Years, 8 Months ago  
Erik,

I get stuck on this line:

Code:


sh-2.05b# ln -s /etc/init.d/goglobalux /etc/rc`grep initdefault
> /etc/inittab|grep -v '^#' |cut -d: -f2`.d/S65goglobalux



I have to do cntl+c, and then this is the output:

Code:


sh: /etc/inittab: Permission denied
ln: creating symbolic link `/etc/rc.d/S65goglobalux' to `/etc/init.d/goglobalux': No such file or directory



Strange, since I am root while doing this ?!?!??

Hadar.


The administrator has disabled public write access.
 
#693
Re: manual install 12 Years, 8 Months ago Karma: 6
Hadar,

You're creating a link to the start-up script so that the "gold" service will always start after a system reboot. This is fully optional.

Be sure to create/type the command in a single line. If that doesn't work, just try

# cd /etc/rc3.d/
# ln -s /etc/init.d/goglobalux S65goglobalux

-Erik
Erikt
Administrator
Posts: 591
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#694
Re: manual install 12 Years, 8 Months ago Karma: 0
Erik,

In Gentoo it works a little bit differently. Just for future reference for all the gentoo people: you need to add the service to the startup script this way:

# rc-update add goglobalux default

that's it.

The server works beautifully. Thanks for all the help.

Hadar.
hadaraz
Fresh Boarder
Posts: 11
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl