Welcome, Guest
Please Login or Register.    Lost Password?

problem with start of "gold" process
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: problem with start of "gold" process
#421
problem with start of "gold" process 13 Years, 2 Months ago Karma: 0
I have a problem with the startup of the "gold" process.

There is a fresh install of the current version of GoGlobal where the "gold" process just refuses to start.

I've debugged "goglobalux start" and the following call in line 166 doesn't work as expected (variables are already expanded):

Code:


/usr/local/graphon/bin/gold -port 491 -sslport 791 -dbhost localhost -dbport 4491 -logfile /usr/local/graphon/etc/gold.log



The output of the command is:

Code:


gold: unknown option: -



followed by the usage options as provided by "gold -help"

Actually, every call besides "gold -version" and "gold -help" fails this way, no matter what arguments are given; the exit code is always 1 in this case.

The logfile "gold.log" is always empty, although the modification time of the file gets updated. The database starts successfully.

The system log gets the message described in the Adminstrator's guide:

Code:


Sep  7 15:43:44 testserv gold[12116]: [ID 633126 user.error] gold: Cybersafe Initialization failed: unable to load library /usr/local/graphon/lib/libcybersafeauth.so: ld.so.1: /usr/local/graphon/bin/gold: fatal: relocation error: file /usr/local/graphon/lib/libcybersafeauth.so: symbol csf_gss_detect_smartcard: referenced symbol not found



There hasn't been any modifications to the config files and all installation options have the default values.

The system on which it should run is:

Code:


# uname -a
SunOS testserv 5.8 Generic_108528-27 sun4u sparc SUNW,Sun-Fire-V250



The version of gold is:

Code:


# ./gold -version
GraphOn Logon Daemon version 2_1_2_656



Any help would be greatly appreciated.
jwesthall
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#424
Re: problem with start of "gold" process 13 Years, 2 Months ago Karma: 2
It almost sounds like you somehow have ended up with a '-' option in your ${GOGLOBAL_ROOT}/etc/gold.conf file. Can you check the contents of this file?

Otherwise, it doesn't look like anything is out of place -- you could try running 'truss" on the startup of the gold process and sending that output to us.

Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#429
Re: problem with start of "gold" process 13 Years, 2 Months ago Karma: 0
It almost sounds like you somehow have ended up with a '-' option in your ${GOGLOBAL_ROOT}/etc/gold.conf file. Can you check the contents of this file?


You're right, that was the problem - a collegue enabled the automatic login feature, but entered an additional '-' in the config file. :?

Thank you for your fast and proficient answer!
jwesthall
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl