Welcome, Guest
Please Login or Register.    Lost Password?
Go to bottomPage: 1
TOPIC: 2.1 upgrade
#405
2.1 upgrade 13 Years, 2 Months ago  
When upgrading from 2.0 to 2.1.2 i get the following:

gold.log
---------
[31 Aug 17:48:03 (I)] Log opened.
[31 Aug 17:48:03 (I)] startup: enabling default authentication methods
[31 Aug 17:48:03 (I)] startup: connecting to database
[31 Aug 17:48:03 (E)] Database connection failed, retrying:
:
: repeats 40 times
:
[31 Aug 17:48:09 (E)] Database connection failed:
[31 Aug 17:48:09 (F)] startup: cannot open database
[31 Aug 17:48:09 (I)] Log closed.

gdbi.log
---------
postmaster successfully started
LOG: could not create IPv6 socket: Invalid argument
LOG: could not resolve "localhost": Temporary failure in name resolution
LOG: database system was shut down at 200info: attempting database connection 0
info: attempting database connection 1
info: attempting database connection 2
info: attempting database connection 3
info: attempting database connection 4
info: attemptingFATAL: database "goglobalux" does not exist
FATAL: database "goglobalux" does not exist
FATAL: database "goglobalux" does not exist
FATAL: database "goglobalux" does not exist
FATAL: database "goglobalux" does not exist
:
: repeats 40 times
:
FATAL: database "goglobalux" does not exist
LOG: received smart shutdown request
LOG: shutting down
LOG: database system is shut down


This runs on a RedHat 7.0 with kernel 2.2.16
Stig Eriksson

The administrator has disabled public write access.
 
#408
Re: 2.1 upgrade 13 Years, 2 Months ago Karma: 2
Hello Stig,

This sounds like your database is having some problems:

LOG: could not create IPv6 socket: Invalid argument

This is probably okay if you are not running IPv6.

LOG: could not resolve "localhost": Temporary failure in name resolution

This may not be, and could be indicative of why the database isn't set up properly. (The installation may have failed because of this.) "Localhost" should be defined in your /etc/hosts file (or in some network-based variant of it).

FATAL: database "goglobalux" does not exist
FATAL: database "goglobalux" does not exist
FATAL: database "goglobalux" does not exist
FATAL: database "goglobalux" does not exist
FATAL: database "goglobalux" does not exist

These errors basically indicate that you have the Postgresql database engine running, but that the 'goglobalux' database was not created.

If you still have the installation logs in /tmp/graphon_installer_logs, they might indicate what happened during the installation.

In the meantime, you can either reinstall the product or try to reinitialize the database.

Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#414
Re: 2.1 upgrade 13 Years, 2 Months ago  
Localhost resolves to 127.0.0.1 in /etc/hosts

This is a part of my /tmp/graphon_installer_logs/goglobal_db_init_messages

postmaster successfully started
info: returned exit code 0
LOG: could not create IPv6 socket: Invalid argument
LOG: could not resolve "localhost": Temporary failure in name resolution
LOG: database system was shut down at 2004-08-31 17:44:18 CEST
LOG: checkpoint record is at 0/8F0D08
LOG: redo record is at 0/8F0D08; undo record is at 0/0; shutdown TRUE
LOG: next transaction ID: 194; next OID: 16938
LOG: database system is ready
info: attempting database connection 0
info: attempting database connection 1
info: attempting database connection 2
...and so on...
start failed
LOG: received smart shutdown request
LOG: shutting down
LOG: database system is shut down

I have tried reinstallation several times, but the results are the same...
Stig Eriksson

The administrator has disabled public write access.
 
#416
Re: 2.1 upgrade 13 Years, 2 Months ago Karma: 2
Localhost resolves to 127.0.0.1 in /etc/hosts

This is a part of my /tmp/graphon_installer_logs/goglobal_db_init_messages


Hello Stig,

The messages from your installation log are almost the same as those when you're trying to start the product, but I'm confused that you get the "FATAL: database 'goglobalux' does not exist" in the startup case (which indicates that the database did start accepting connections) whereas in the installation case it appears not to have ever started accepting connections.

I do think the root of the problem is that message about being unable to resolve localhost, even though it's listed in /etc/hosts, do you have an /etc/nsswitch.conf that perhaps doesn't refer to "files" in the section describing "hosts"? What do you get if you run "nslookup localhost"?

Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#420
2.1 upgrade 13 Years, 2 Months ago  
The /etc/nsswitch.conf contains
hosts: files

/etc/resolv.conf is empty

nslookup localhost results in
Server: kung
Address: 0.0.0.0

*** kung can't find localhost: No response from server

This is a completely stand-alone system, with no access to the rest of the world, so there is no nameserver running, and no access to any external nameservers.
Stig Eriksson

The administrator has disabled public write access.
 
#428
Re: 2.1 upgrade 13 Years, 2 Months ago  
Localhost resolves to 127.0.0.1 in /etc/hosts

This is a part of my /tmp/graphon_installer_logs/goglobal_db_init_messages

postmaster successfully started
info: returned exit code 0
LOG: could not create IPv6 socket: Invalid argument
LOG: could not resolve "localhost": Temporary failure in name resolution
LOG: database system was shut down at 2004-08-31 17:44:18 CEST
LOG: checkpoint record is at 0/8F0D08
LOG: redo record is at 0/8F0D08; undo record is at 0/0; shutdown TRUE
LOG: next transaction ID: 194; next OID: 16938
LOG: database system is ready
info: attempting database connection 0
info: attempting database connection 1
info: attempting database connection 2
...and so on...
start failed
LOG: received smart shutdown request
LOG: shutting down
LOG: database system is shut down

I have tried reinstallation several times, but the results are the same...
Stig Eriksson

The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl