Welcome, Guest
Please Login or Register.    Lost Password?

Same account multiple sessons
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: Same account multiple sessons
#3745
Same account multiple sessons 4 Years, 7 Months ago Karma: 0
Hi Community.

I have just insalled and configured a goglobal 2.2.4 for unix on my SLES 10 SP4. clients are meant to access using windows machines.

I just noticed that a user, called "test" for example, can be used by more than one person at the time for accessing the server using goglobal. I dont want this. I want that every user use their own account, and if someone tries to use an account that is already logged on in goglobal, that users get a notification or an error message. Hope makes sense.

thanks for your help in advance

Marco Salazar
maludh
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#3760
Re:Same account multiple sessons 4 Years, 5 Months ago Karma: 2
Hi Marco,

Sorry for the late response but I was browsing through here and saw your question. I think that you can get the behavior you're looking for by using the "pam_limits.so" module. Check your PAM configuration (in /etc/pam.d/goglobal) to ensure that it's enabled, then you can configure it via /etc/security/limits.conf (or /etc/security/limits.d/). For example, in your case you could add a line to /etc/security/limits.conf like:

Code:

test       -      maxlogins      1



You can specify usernames, or group names with and @ symbol (like '@users') or everyone with "*" (although root is not limited).

Hope this helps,
Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
Last Edit: 2013/04/30 00:58 By troy.
The administrator has disabled public write access.
 
#3761
Re:Same account multiple sessons 4 Years, 5 Months ago Karma: 0
Hi Troy. Thanks for your response.

The product Im installing requiere me to do the following steps:

Edit the GO-Global gold.conf file:
“cd /opt/graphon/etc”[Return]

Change the row:

auth = pam

To read in this way:

auth = pass

Save and exit


Also, I am required to change the ‘/etc/nsswitch.conf’, I think also here I had to change some "pam" parameters. the product require this file to be read as:

‘passwd: files’

‘group: files’

‘hosts: files’

‘networks: files’

‘protocols: files’

‘rpc: files’

‘publickey: files’

‘netgroup: files’

‘automount: files’

‘aliases: files’

‘services: files’


I unfortunately don't know if this will have some impact on the procedure you suggest. I will anyway give it a try.

Thanks a lot
maludh
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#3762
Re:Same account multiple sessons 4 Years, 5 Months ago Karma: 2
Hi Marco,

If you have auth=pass set, then my suggestion won't help. What I suggested relies on the PAM subsystem to enforce the limits when the user logs in.

Unfortunately, the only other way to do what you want is probably too complex, but you could write a script to wrap whatever application or session you are currently publishing. The new wrapper script would check for multiple logins and, if present, abort the session, otherwise start the session/application normally. Something like this might work:

Code:

#!/bin/sh

MAXUSERS=1               # change to number of allowed logins
COMMAND=/usr/bin/xterm   # change to command to run if allowed

whoami=`whoami`
logincount=`who | grep $whoami | grep gold: | wc -l`

if [ $logincount -gt $MAXUSERS ]
then
    /usr/bin/xmessage "Too many logins as $whoami.  This session will be aborted.

Currently $logincount logins, only $MAXUSERS allowed."
    exit
fi

exec $COMMAND



I've only lightly tested that script, and there are obviously other ways it could be done or enhanced, but hopefully that gets the idea across.

Hope this helps,
Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl