Welcome, Guest
Please Login or Register.    Lost Password?

GG2.2.17, RH6.3 PAM authentication problem
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: GG2.2.17, RH6.3 PAM authentication problem
#3729
GG2.2.17, RH6.3 PAM authentication problem 4 Years, 10 Months ago Karma: 0
Hi. I'm having a problem with authentication when using the silent install method for Go-Global 2.2.17 on RedHat 6.3 (and CentOS 6.3).

If I do a silent install using the following parameters:

GRAPHON_INSTALLER_OPTIONS="batch=y,target=/usr/local/graphon,port=491,sslport=791,user=username" /mnt/temp/gg2.2.17/GO-Global_for_UNIX-RedHat_Enterprise_Linux-6.2-x86_64.bin

(substitue username for our GG user)

it installs ok but when someone tries to login, they get authentication errors and it drops them immediately. We don't even get prompted for a username, etc.

We're using PAM for authentication. I checked the /usr/local/graphon/etc/gold.conf file and its set for pam authentication.

If I do a manual install on the same system with the above options and select pam for authentication, it works fine.

One other odd thing, if I do a manual install, remove it, then do a silent install, it works ok.

Anyone encountered this and have a fix?

Thanks.
mharr1
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#3730
Re:GG2.2.17, RH6.3 PAM authentication problem 4 Years, 10 Months ago Karma: 6
It might have something to do with the creation of the 'flexlm' user but I can't be sure. I'll see if I can have somebody else look at this.
Erikt
Administrator
Posts: 591
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#3731
Re:GG2.2.17, RH6.3 PAM authentication problem 4 Years, 10 Months ago Karma: 2
It's impossible for me to be sure, but you almost certainly need to configure your PAM system to allow logins from GO-Global. This can be done by modifying the /etc/pam.d/other file (which is the fallback), or by creating a new /etc/pam.d/goglobal profile.

(The install does not configure PAM without confirmation by the user because an improper configuration could introduce security vulnerabilities to the system. During an interactive install, we'll request confirmation before doing it but since there's no way to ask during a batch mode install, it is always skipped.)

Assuming that this is the problem, it can usually be corrected by running:

Code:


    # cp /etc/pam.d/login /etc/pam.d/goglobal



I say "usually" because PAM configurations are system-specific and can be customized beyond our ability to support directly (but if you have the default PAM configuration the above command should fix it). Let us know how you get on.

Thanks,
Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl