Welcome, Guest
Please Login or Register.    Lost Password?

GoGlobal client running on linux machine with nVidia drivers
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: GoGlobal client running on linux machine with nVidia drivers
#336
GoGlobal client running on linux machine with nVidia drivers 13 Years, 4 Months ago Karma: 0
We've got several Linux machines with nVidia graphics cards in them. We've found that if we use the nVidia graphics drivers (downloadable from nVidia's website), when you run GoGlobal you aren't able to see any fonts -- sometimes they show up as thin underscore lines, and sometimes are completely blank. All of the servers we're connecting to run GoGlobal server under Solaris.

Right now, we're running GoGlobal 2.0 across the board, but I've also seen the problem in the newer GoGlobal release.

Has anyone else run into this problem? If you have, are there server or client settings I should be using?

Thanks,

-- jeremy
jrosengren
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#355
Re: GoGlobal client running on linux machine with nVidia drivers 13 Years, 4 Months ago Karma: 6
Jeremy,

While not impossible, I doubt that the problem is specific to nVidia display drivers. We have found that more often than not, Linux servers utilize a font server and you might try pointing to a font server.

You can add "tcp/10.0.0.1:7100" in the prepend/append list within GO-Configure.

Note above 10.0.0.1 is the host running the font server, and 7100 is the
(default) xfs port the font server is running on.

The syntax can also be:

tcp/localhost:7100 (font server listening on TCP port 7100 on this host)
tcp/hostname:7100 (font server listening on TCP port 7100 on hostname)
unix/:7100 (font server listening on UNIX domain socket 7100)

From within a GO-Global session, you can enable it as follows:

xset +fp tcp/localhost:7100

Hope that helps,

-Erik
Erikt
Administrator
Posts: 591
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#357
Re: GoGlobal client running on linux machine with nVidia drivers 13 Years, 4 Months ago  
Thanks for the tip, Erik. I'll go ahead and try that, however I have confirmed that by simply changing back and forth between the nVidia display driver and the generic driver that comes with RedHat, I can see the problem come and go. It seems odd that simply changing the display driver would have an effect on the font server.

I'll give it a shot anyway, and report here.

Thanks again,

-- jeremy


The administrator has disabled public write access.
 
#1452
Seeing this, too 11 Years, 3 Months ago Karma: 0
I'm seeing the exact same problem. I can use the default drivers, and I can see fonts just fine, but when I switch to nVidia drivers, no fonts appear (except for the occasional undescore). I'm using the go global client under linux, but the server is on an AIX machine, so I'm guessing the various font server issues mentioned before don't apply?
jason0x21
Fresh Boarder
Posts: 1
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#1509
Re; Display problems 11 Years, 2 Months ago Karma: 0
Hi,

For what it's worth, I'm seeing display problems on the Linux native client with or without nVidia drivers - makes no difference. (nvidia FX5200 Ultra to be specific)
garethbult
Fresh Boarder
Posts: 12
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl