Welcome, Guest
Please Login or Register.    Lost Password?

Service failed. (X:3:2263:2)
(1 viewing) (1) Guest
Go to bottomPage: 12
TOPIC: Service failed. (X:3:2263:2)
#300
Service failed. (X:3:2263:2) 13 Years, 6 Months ago Karma: 0
Started receiving this message today when starting the xterm client. Not having any issues with the other hosts that I connect to, the host is not reporting any errors. Re-initialized the database and restarted the client without any errors. Also receive startup failed message after the service failed message. The client seems to connect properly even allowing authentication to the workstation. This is a SunOS workstation and I am using GoGlobal 2.1.2 client. Any help would be greatly appreciated.
hmacjr
Fresh Boarder
Posts: 4
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#302
Re: Service failed. (X:3:2263:2) 13 Years, 6 Months ago Karma: 2
This usually indicates that the server was unable to start the X session on the server. Normally we'd have to see the session log from the ${HOME}/.graphon/session-logs/ directory. You may want to e-mail this log to support@graphon.com to follow up.

If you've recently made changes to your .profile, .cshrc, etc., configuration files those could be causing problems, since errors in those files can cause the X session startup to fail.

Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#303
Re: Service failed. (X:3:2263:2) 13 Years, 6 Months ago Karma: 0
Troy,

No changes have been made in profile. There are no sessions logs currently in the directory. Tried to run the go-configure utility to see if any changes had been made and I received "could not start X server". I don't normally use this workstation but I doubt any changes would have been made only a couple of users have access to root. Any ideas?

Many thanks,

Hal
hmacjr
Fresh Boarder
Posts: 4
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#306
Re: Service failed. (X:3:2263:2) 13 Years, 6 Months ago Karma: 2
Hi Hal,

If nothing has changed, then it works exactly the way it always has, right?

Seriously, though, the one case that we have heard about symptoms like this turned out to be bad hardware causing random problems starting the sessions.

I would try to troubleshoot this by using a system-call tracing utility (like truss or strace or tusc, depending on what platform you are using) to see what happens when you try to launch your session. By tracing gold, you should be able to see it start a shell, and see the shell do some processing and then eventually start xinit, which will start Xgo, and so on. Somewhere in there an error is occuring. If you can create the trace (be sure to use the '-f' switch or equivelant to trace children processes) you could send that to us and we could try to determine the problem from that.

I hope this information helps.

Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#310
Re: Service failed. (X:3:2263:2) 13 Years, 6 Months ago Karma: 0
Thanks,

I will give that a go.....

Hal
hmacjr
Fresh Boarder
Posts: 4
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#395
Re: Service failed. (X:3:2263:2) 13 Years, 3 Months ago  
I've got the same symptons on our SunFire 210/Solaris 9 system. I recently installed GoGloal on the production server (so nothing should really change...).

The system worked fine. Last week it stopped. A non-proviledged user can log in over GoGlobal, but cannot start any X stuff (xterm/cde/openwin/netscape et al.)

The /var/adm/messages shows:
Aug 23 11:21:03 gateway gold[484]: [ID 830395 user.crit] session: failed to start application
Aug 23 11:21:03 gateway gold[484]: [ID 830395 user.crit] session: failed to start application

When I try and start some X stuff the GoGlobal client gives the error:
Service Failed. (-X:1:660:3)

The interesting thing is that if I log on as root there is no problem. Some permissions must have changed somewhere, me thinks.

Any one have any ideas?

Zii..
zii

The administrator has disabled public write access.
 
Go to topPage: 12
Moderators: troy, Andyl