Welcome, Guest
Please Login or Register.    Lost Password?

Error when connecting from Windows native client
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: Error when connecting from Windows native client
#266
Error when connecting from Windows native client 13 Years, 7 Months ago  
When connecting from a windows client
I get the following error in gold.log.

[21 Apr 21:22:06 (F)] ConnectionServer -- error accepting connection

Host OS is Solaris 2.6 UNIX host 2.1

Client is the 2.1.1 639.

Looking at the TCP connection I see the syn, syn ack and ack all proper then the host initiates a fin back to the client immediately. Of course the connection closes. I tried stopping and starting gold to no avail.

I tried to find any required system patches to no avail. I have a second host that is working fine. Also I can connect to the non working host from another client that is working.

Any ideas would be appreciated.

Thanks,
KenMcV

The administrator has disabled public write access.
 
#268
Re: Error when connecting from Windows native client 13 Years, 7 Months ago Karma: 2
Ken,

If you are using SSL, please check to see that your host has the following files in ${GOGLOBAL_ROOT}/ssl/certs:
    [li]server.key
    [li]server.crt

If these are not present, you can create them using the following steps (as root):

Code:

# cd ${GOGLOBAL_ROOT}
# GOGLOBAL_ROOT=`pwd`  # sh syntax, use setenv for csh
# export GOGLOBAL_ROOT
# bin/mkcert.sh



This could also be caused by the system being out of resources, though this seems unlikely.

You should also make sure that you are connecting to the correct port using the correct transport, but from your description of the TCP traffic I don't believe this is what you are seeing.

Thanks,
Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#271
Re: Error when connecting from Windows native client 13 Years, 7 Months ago  
Thanks re-generating the certificate worked. I also later noticed that I could connect on 491 but not 791. Also pointing to a certificate problem. I don't know what heppened to the certificate on install or after.
KenMcV

The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl