Welcome, Guest
Please Login or Register.    Lost Password?

Excessive CPU Load using XDM Direct Mode
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: Excessive CPU Load using XDM Direct Mode
#2560
Excessive CPU Load using XDM Direct Mode 9 Years, 7 Months ago Karma: 0
I have created a 'subsession' with the following characteristics:

1) Main session login is 'root@<IP of host>'
2) XDM Mode: Direct Query
3) XDMCP Host: localhost

This presents the server OS' graphical login screen and one can login as any valid user. The problem is that the CPU load is through the roof! When a non-direct XDM mode is used, this is not the case.

How can I lower the load on the server cpu?

Thanks.
buckberger
Fresh Boarder
Posts: 5
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#2568
Re:Excessive CPU Load using XDM Direct Mode 9 Years, 6 Months ago Karma: 2
Not sure why this would happen. What process(es?) are using the CPU the most?

Thanks,
Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#2569
Re:Excessive CPU Load using XDM Direct Mode 9 Years, 6 Months ago Karma: 0
When this happens the following two processes use excessive cpu capacity:

/usr/local/graphon/bin/Xgo :2 -once -query localhost -screen 0 0x0x0 -tune -sin (cut off here)

goclip

As a reference point, on one of our Sun V240's, these two processes use:

Xgo 25.3%
goclip 22.7%

When I run a non-XDM direct session, these numbers are:

Xgo 0.8%
goclip 0.3%

were all other process loads are common to these numbers.
buckberger
Fresh Boarder
Posts: 5
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#2570
Re:Excessive CPU Load using XDM Direct Mode 9 Years, 6 Months ago Karma: 2
If this is an older version of the product, there was a bug that was caused by this sort of session where the clipboard process (goclip) would attempt to connect to the X server (Xgo) in a tight loop without the proper credentials, and Xgo would have to process and reject each of these connections. Between the two of them, they used a considerable amount of CPU.

As a workaround, you can disable goclip by changing its permissions:

# chmod 0 ${GOGLOBAL_ROOT}/bin/goclip

Alternatively, upgrading to the most recent release (2.2.8 as of this writing) should fix the problem as well.

Hope this helps,
Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#2571
Re:Excessive CPU Load using XDM Direct Mode 9 Years, 6 Months ago Karma: 0
Thanks! It works fine.
buckberger
Fresh Boarder
Posts: 5
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#2574
Re:Excessive CPU Load using XDM Direct Mode 9 Years, 6 Months ago Karma: 2
Glad that that fixed it. Note that this effectively disables the synchronization of clipboard between UNIX and Windows, so if you need that functionality back you'll probably need to look at upgrading.

Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl