Welcome, Guest
Please Login or Register.    Lost Password?

goglobal doesnot start
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: goglobal doesnot start
#2530
goglobal doesnot start 9 Years, 8 Months ago Karma: 0
i have goglobal ux version 2.1.4_716
it is not starting

nmrm4wtd,sys,root # /sbin/init.d/goglobalux start
INFORMATION: No server defined in /opt/graphon/etc/license_server.dat
Local license file /opt/graphon/etc/license.dat will be used
Starting the database: FAILED.
See /var//opt/graphon/log//gdbi.log for more information.
Starting the GraphOn Login Daemon: FAILED.
A likely cause is that another program is listening on TCP port 491 or
791. Look for the message "startup: unable to create any listening
sockets" in /var//opt/graphon/log//gold.log, then either free the TCP
ports 491 and 791 or specify a different value for GOLD_PORT and
GOLD_SSL_PORT in /opt/graphon/etc/goglobalux.

Another likely cause is that the gold daemon could not connect to the
database. Look for the message "startup: cannot open database" in
/var//opt/graphon/log//gold.log, then check
/var//opt/graphon/log//gdbi.log for suggestions.




then i look into the log file gdbi.log and i get


nmrm4wtd,sys,root # more /var//opt/graphon/log//gdbi.log
info: executing '/opt/graphon/postgresql/bin/pg_ctl -D /opt/graphon/postgresql/d
ata -o '-i -p 4491 -N 16 -B 33 ' start'
/opt/graphon/postgresql/bin/pg_ctl[70]: /dev/null: Cannot create the specified f
ile.
/opt/graphon/postgresql/bin/pg_ctl[82]: /dev/null: Cannot create the specified f
ile.
The programs "postmaster" and "psql" are needed by pg_ctl but
were not found in the directory "/stuff/tmp/pg_make/snoopy/out/bin".
Check your installation.
info: returned exit code 256
info: attempting database connection 0
info: attempting database connection 1
info: attempting database connection 2
info: attempting database connection 3
info: attempting database connection 4
info: attempting database connection 5
info: attempting database connection 6
info: attempting database connection 7
info: attempting database connection 8
info: attempting database connection 9
info: attempting database connection 10
info: attempting database connection 11
info: attempting database connection 12
info: attempting database connection 13
info: attempting database connection 14
info: attempting database connection 15


then i tried like in the forum to create new db
that is what i got

nmrm4wtd,sys,root # ./gdbi -dbuser goglobal -dbport 4491
GOGLOBAL_ROOT set to '/opt/graphon'
Please set GOGLOBAL_ROOT before running initdb
Opening pipe (/opt/graphon/postgresql/bin/postgres -O -F -D /opt/graphon/postgre
sql/data template1)......pipe opened...
POSTGRES backend interactive interface
$Revision: 1.375.2.1 $ $Date: 2003/11/24 14:50:02 $

backend> backend> ...pipe closed, exit 0
info: executing '/opt/graphon/postgresql/bin/pg_ctl -D /opt/graphon/postgresql/d
ata -o '-i -p 4491 -N 16 -B 33 ' start'
/opt/graphon/postgresql/bin/pg_ctl[70]: /dev/null: Cannot create the specified f
ile.
/opt/graphon/postgresql/bin/pg_ctl[82]: /dev/null: Cannot create the specified f
ile.
The programs "postmaster" and "psql" are needed by pg_ctl but
were not found in the directory "/stuff/tmp/pg_make/snoopy/out/bin".
Check your installation.
info: returned exit code 256
info: attempting database connection 0
info: attempting database connection 1
info: attempting database connection 2
info: attempting database connection 3



a little help would be nice
leo wenth
Fresh Boarder
Posts: 1
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#2537
Re:goglobal doesnot start 9 Years, 7 Months ago Karma: 0
Hi Leo,

I think I've had the same issue some ages ago when I installed the host on /opt instead of the default in /usr/local

Does your folder look like this ?
drwxr-xr-x 2 root sys 4096 Jul 21 2006 goglobal

You should try to go to the /opt directory as root and then try "chmod 755 graphon". (Non-recursive!)

I think it worked then.....

Greetz

michael
micmanders
Fresh Boarder
Posts: 5
graphgraph
User Offline Click here to see the profile of this user
Gender: Male micmanders Location: Germany Birthday: 09/05
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl