Welcome, Guest
Please Login or Register.    Lost Password?

Failed to create lock file on NFS homedir
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: Failed to create lock file on NFS homedir
#2454
Failed to create lock file on NFS homedir 9 Years, 8 Months ago Karma: 0
I am testing GGUX 227 and have come across the following messages after exiting a session:

Failed to create lock file candidate...Permission denied
maintenance aborted: maintenance pid 6101 still running

gold is running as root, and the user's homedir is on an NFS drive where root on the goglobal server does not have write permission. (goglobal creates the ~/.graphon dir with 755 perms). Changing the .graphon dir to 777 perms usually helps, but is not a long term solution. Never saw this problem before, maybe the maintenance task has changed in 277?

Thanks,

Moshe
mlinzer
Fresh Boarder
Posts: 13
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#2516
Re: Failed to create lock file on NFS homedir 9 Years, 8 Months ago Karma: 2
Moshe,

In general if you have the situation that you're describing (user home directories are mounted from an NFS source that does not allow root access), we recommend that you place the "per-user database" files in an alternate location (not in the user's home directories). You can do this by editing ${GOGLOBAL_ROOT}/etc/xmldb.conf, and changing the value for userdb to something like:

Code:

userdb = ${GOGLOBAL_ROOT}/db/


You will probably want to create the ${GOGLOBAL_ROOT}/db/ directory and set its permissions to 1777.

Note that this will cause the per-user database files to become per-machine also. If this is undesirable, you'd probably have to provide an alternate NFS share for the user-databases that does allow root access (and only store user database files on that share).

Hope this helps,
Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
Last Edit: 2012/03/30 16:08 By troy.Reason: corrected boardcode
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl