Welcome, Guest
Please Login or Register.    Lost Password?

Database reinitialization failed
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: Database reinitialization failed
#225
Database reinitialization failed 13 Years, 7 Months ago  
After installing Go-Global UX 2.1 on a HP UX Server, I couldn't manage to start server : this is gold.log :

--------------------------------------
[30 Mar 13:38:57 (I)] Log opened.
[30 Mar 13:38:57 (I)] startup: enabling default authentication methods
[30 Mar 13:38:57 (I)] startup: connecting to database
[30 Mar 13:38:57 (E)] Database connection failed, retrying:
[30 Mar 13:38:57 (E)] Database connection failed, retrying:
...
etc
...
[30 Mar 13:39:02 (E)] Database connection failed, retrying:
[30 Mar 13:39:02 (E)] Database connection failed:
[30 Mar 13:39:02 (F)] startup: cannot open database
[30 Mar 13:39:02 (I)] Log closed.
--------------------------------------
So I tried to reinitialize database with this procedure.
And I get the following logs :

--------------------------------------
# bin/gdbi -dbuser admin -dbport 4491
GOGLOBAL_ROOT set to '/opt/graphon'
The files belonging to this database system will be owned by user "admin".
This user must also own the server process.

The database cluster will be initialized with locale C.

fixing permissions on existing directory /opt/graphon/postgresql/data... ok
creating directory /opt/graphon/postgresql/data/base... ok
creating directory /opt/graphon/postgresql/data/global... ok
creating directory /opt/graphon/postgresql/data/pg_xlog... ok
creating directory /opt/graphon/postgresql/data/pg_clog... ok
selecting default max_connections... 1
selecting default shared_buffers... 2
creating configuration files... ok
creating template1 database in /opt/graphon/postgresql/data/base/1... FATAL: 2 is outside the valid range for parameter "shared_buffers" (16 .. 2147483647)

initdb: failed
Opening pipe (/opt/graphon/postgresql/bin/postgres -O -F -D /opt/graphon/postgresql/data template1)......pipe opened...FATAL: 2 is outside the valid range for parameter "shared_buffers" (16 .. 2147483647)
...pipe closed, exit 1
setpassword failed
-----------------------------------------

How can I set this "shared_buffer" parameter ?
What is the problem ?
rlorient

The administrator has disabled public write access.
 
#226
Re: Database reinitialization failed 13 Years, 7 Months ago Karma: 2
Hi,

This looks like a combination of two things. First of all, you can probably fix the problem on your system by increasing the amount of shared memory available to processes. On HP-UX, IPC parameters can be set in the System Administration Manager (SAM) under Kernel Configuration->Configurable Parameters. Hit Create A New Kernel when you're done.

Check the values for shmmax, shmmni, semmap, and semmns.

The values we are using here are:

Code:

SHMMAX     1073741824
SHMMNI     200
SEMMAP     66
SEMMNS     128



Let us know if you continue to encounter problems.

Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#227
Re: Database reinitialization failed 13 Years, 7 Months ago  
Hi Troy,

I have just checked the 4 parameters. These are their values on my server :

SHMMAX 1073741824
SHMMNI 200
SEMMAP 130
SEMMNS 512

Do I really need to increase shared memory ?

I also tried to start database with the following command and this is the result :

-----------------------------------------------
$ /opt/graphon/bin/gdbi -ggroot /opt/graphon -dbuser admin -dbport 4491 start
GOGLOBAL_ROOT set to '/opt/graphon'
/opt/graphon/postgresql/bin/postmaster: could not find the database system
Expected to find it in the directory "/opt/graphon/postgresql/data",
but could not open file "/opt/graphon/postgresql/data/global/pg_control": No such file or directory
postmaster successfully started
-----------------------------------------------

Regis LORIENT
rlorient

The administrator has disabled public write access.
 
#233
Re: Database reinitialization failed 13 Years, 7 Months ago Karma: 2
I have just checked the 4 parameters. These are their values on my server :

SHMMAX 1073741824
SHMMNI 200
SEMMAP 130
SEMMNS 512

Do I really need to increase shared memory ?


From the error that was reported when you tried to initialize the database it would appear that most (or all) of the shared memory segments on your system are in use. You should be able to use the "ipcs" command to view the current usage of the SystemV IPC elements (shared memory, semaphores, etc). At this point, my suspicion would be that you might need to increase the "SHMNMI" parameter.

I also tried to start database with the following command and this is the result :

-----------------------------------------------
$ /opt/graphon/bin/gdbi -ggroot /opt/graphon -dbuser admin -dbport 4491 start
GOGLOBAL_ROOT set to '/opt/graphon'
/opt/graphon/postgresql/bin/postmaster: could not find the database system
Expected to find it in the directory "/opt/graphon/postgresql/data",
but could not open file "/opt/graphon/postgresql/data/global/pg_control": No such file or directory
postmaster successfully started
-----------------------------------------------


This makes sense, since your database directory was never completely initialized, it isn't a vlid database directory yet. You might also have to try to determine if there is another program using all the shared memory resources, temporarily shut it down, reinitialize your database, start the GO-Global database, then restart the other program. GO-Global's database does not use all of the available resources, though it's conceivable that other programs might.

Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#235
Re: Database reinitialization failed 13 Years, 7 Months ago  
I rebooted my server. As a consequence, database reinitialization worked well. As this server was running for a long time, I think it had loss of memory problems.

Thank you for your help.

Regis LORIENT
rlorient

The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl