Welcome, Guest
Please Login or Register.    Lost Password?
Go to bottomPage: 1
TOPIC: shell substitution
#1625
shell substitution 10 Years, 10 Months ago Karma: 0
When I launch an Xterm session I see in the master log the message:
pam-login: substituting shell /home/bin/tcsh with /bin/sh
And indeed, when I open the Xterm window, I get a /bin/sh prompt instead of my tcsh prompt. Why is this happening and how can I change this behaviour?

thanks,

Moshe
mlinzer
Fresh Boarder
Posts: 13
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#1628
Re: shell substitution 10 Years, 10 Months ago Karma: 0
seems like this was introduced in 2.2.3, it does not exist in 2.2.2. Can anybody relate?
mlinzer
Fresh Boarder
Posts: 13
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#1633
Re: shell substitution 10 Years, 10 Months ago Karma: 2
A modification was made between v2.2.2 and v2.2.3 to better support the convention of using a "fake" shell to prevent logins (such as /bin/true or /bin/false). The problem with such conventions is that GO-Global for UNIX obviously cannot use them to launch sessions.

Therefore if the user's shell is not present in /etc/shells, GO-Global for UNIX will use a default /bin/sh shell instead. You should be able to resolve this by ensuring that /home/bin/tcsh is listed in /etc/shells, which will make it a "valid" shell.

Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#1636
Re: shell substitution 10 Years, 10 Months ago Karma: 0
Cool trick, thanks for the tip troy!
mlinzer
Fresh Boarder
Posts: 13
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl