Welcome, Guest
Please Login or Register.    Lost Password?

Can't display anything on Solaris server
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: Can't display anything on Solaris server
#1477
Can't display anything on Solaris server 11 Years, 3 Months ago Karma: 0
I have (2) RHEL4-AMD64 machines working fine with GoGlobalUX 2.2.0, but I can't get my Solaris 9 machine to work. The LDAP authentication works great, but none of the programs work. At first I had trouble with permissions of /tmp/.gg-unix but that's been fixed. Here's a sample of the log file of a current session:

Code:


cat summersd-:3-session.log
cmdline is --serverOpts -clienttype Win32 -screen 0 2304x1024x24 -multiwindow -tune -mousedowninterval 40 -mouseupinterval 150 -dpi 75 -cachesize 16384 -compresscache -cachecompressionthreshold 64 --clientCommand /opt/graphon/bin/gowm
Host Information: SunOS ucl-luxor 5.9 Generic_118558-30 sun4u sparc SUNW,Sun-Blade-100
startXgo.sh: GOGLOBAL_ROOT is /opt/graphon
appending /usr/openwin/lib/X11/fonts/F3bitmaps/
appending /usr/openwin/lib/X11/fonts/Type1/
appending /usr/openwin/lib/X11/fonts/misc/
appending /usr/openwin/lib/X11/fonts/75dpi/
appending /usr/openwin/lib/X11/fonts/100dpi/
appending /usr/openwin/lib/X11/fonts/Xt+/
startXgo.sh: /opt/graphon/bin/xinit /opt/graphon/bin/gowm -- /opt/graphon/bin/Xgo :3 -clienttype Win32 -screen 0 2304x1024x24 -multiwindow -tune -mousedowninterval 40 -mouseupinterval 150 -dpi 75 -cachesize 16384 -compresscache -cachecompressionthreshold 64 -fp /opt/graphon/lib/fonts/,/usr/openwin/lib/X11/fonts/F3bitmaps/,/usr/openwin/lib/X11/fonts/Type1/,/usr/openwin/lib/X11/fonts/misc/,/usr/openwin/lib/X11/fonts/75dpi/,/usr/openwin/lib/X11/fonts/100dpi/,/usr/openwin/lib/X11/fonts/Xt+/ -co /usr/openwin/lib/rgb -smartparent -cmapopt -sp /opt/graphon/lib/X11/xserver/SecurityPolicy
-------------------------------------------------------------------------------
xinit: using displayNum :3

xinit: Executing server
Xgo bound to processor 0
(default) [25 Aug 12:16:39]: base[6]: CS_ComponentServer::initialize
ready to accept connection from gold
making peername atom as 0.0.0.0
Initializing extensions
GOCLIP: Adding extension
GOCLIP: extension event base = 64
GOFILE: Adding extension
GOFILE: extension event base = 65
GOPRINT: Adding extension
GOPRINT: extension event base = 67
Extensions initialized
connection from gold daemon accepted
(default) [25 Aug 12:16:39]: base[6]: CS_Connection::onConnect: latency of connection to /tmp/.gg-unix/GG3 = 0.240 ms
(default) [25 Aug 12:16:39]: base[6]: CS_Connection::onConnect: platform = gold
(default) [25 Aug 12:16:39]: base[6]: CS_Connection::onConnect: language = en_US
(default) [25 Aug 12:16:39]: base[6]: connection to /tmp/.gg-unix/GG3 m_ping_timeout=60000 m_input_timeout = 60000
(default) [25 Aug 12:16:39]: xgo[6]: startng messageLoop
(default) [25 Aug 12:16:39]: base[6]: Component::processRequest NewInstance id=32769 class=GraphOn::GO-Global UX::ApplicationControlServer
Controller created
(default) [25 Aug 12:16:39]: base[6]: Component::processRequest NewInstance id=32770 class=GraphOn::ComponentServer::Bridge
(default) [25 Aug 12:16:39]: base[6]: CS_Bridge::initialize bridge
(default) [25 Aug 12:16:39]: xgo[6]: bridge created
added fd=10
Creating BridgeInputHandler
(default) [25 Aug 12:16:39]: base[6]: CS_Bridge::processRequest SetPeerName peer=9.76.201.22
(default) [25 Aug 12:16:39]: xgo[6]: bridge established
setting peername atom to 9.76.201.22
(default) [25 Aug 12:16:39]: base[6]: CS_Bridge::processRequest SetName name=X:3:1929:gowm
(default) [25 Aug 12:16:39]: app[7]: AC_START component = 0x003E6908, fast_link= false
Start bridge on connection to /tmp/.gg-unix/GG3
FetchClientInfo wgi=3ef918
FetchClientInfo getting info
FetchClientInfo got info



Code:


cat summersd-ucl-luxor-leader.log
(leader) [25 Aug 12:16:24]: leader[6]: redirecting stdin/stdout to log
(leader) [25 Aug 12:16:24]: leader[5]: making database from conf /opt/graphon/etc/xmldb.conf
(leader) [25 Aug 12:16:25]: leader[6]: client info reported client   = Win32
(leader) [25 Aug 12:16:25]: leader[6]: client info reported language = en_US
(leader) [25 Aug 12:16:25]: leader[6]: client info reported keyboard = en_US
(leader) [25 Aug 12:16:25]: leader[6]: client info reported timezone = PacificStandardTime+08:00PacificDaylightTime
(leader) [25 Aug 12:16:25]: leader[6]: client info reported dblclick = 500
(leader) [25 Aug 12:16:25]: leader[6]: client info reported screen (w,h,d,ad)= (2304,1024,32,8)
(leader) [25 Aug 12:16:25]: leader[6]: client info reported work area (x,y,w,h)= (4,23,1272,937)
(leader) [25 Aug 12:16:25]: leader[6]: locale set to "C"
(leader) [25 Aug 12:16:25]: leader[6]: timezone set to "PST8PDT"
(leader) [25 Aug 12:16:25]: leader[6]: LANG=C TZ==PST8PDT
(leader) [25 Aug 12:16:25]: session[6]: sending 0 running items
(leader) [25 Aug 12:16:25]: session[6]: sending 0 suspended items
(leader) [25 Aug 12:16:25]: session[6]: sending 7 configured items
(leader) [25 Aug 12:16:37]: leader[5]: Execing (from constructor): /opt/graphon/bin/startXgo.sh --serverOpts -clienttype Win32 -screen 0 2304x1024x24 -multiwindow -tune -mousedowninterval 40 -mouseupinterval 150 -dpi 75 -cachesize 16384 -compresscache -cachecompressionthreshold 64  --clientCommand /opt/graphon/bin/gowm
(leader) [25 Aug 12:16:37]: launch[6]: got pid 1929
(leader) [25 Aug 12:16:37]: launch[6]: connecting to Xgo 3
(leader) [25 Aug 12:16:37]: socket[3]: socket /tmp/.gg-unix/GG3: unable to Connect: Unable to connect to /tmp/.gg-unix/GG3:
No such file or directory (errno=2)
(leader) [25 Aug 12:16:37]: leader[6]: Xgo 3 not ready yet ... will retry
(leader) [25 Aug 12:16:38]: socket[3]: socket /tmp/.gg-unix/GG3: unable to Connect: Unable to connect to /tmp/.gg-unix/GG3:
No such file or directory (errno=2)
(leader) [25 Aug 12:16:38]: leader[6]: Xgo 3 not ready yet ... will retry
(leader) [25 Aug 12:16:39]: launch[6]: connected to Xgo 3
(leader) [25 Aug 12:16:39]: launch[6]: setting bridge name X:3:1929:gowm
(leader) [25 Aug 12:16:39]: leader[6]: Checking if display 3 is ready yet
(leader) [25 Aug 12:16:39]: leader[6]: Display 3 ready
(leader) [25 Aug 12:16:40]: leader[5]: Execing (from launch): /usr/openwin/bin/xterm
(leader) [25 Aug 12:16:40]: session[6]: sending 1 running items
(leader) [25 Aug 12:16:40]: session[6]: sending 0 suspended items
(leader) [25 Aug 12:16:40]: session[6]: sending 7 configured items



The xterm window never displays.

Doug
summersd619
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#2491
Re: Can't display anything on Solaris server 9 Years, 8 Months ago Karma: 0
I am also having a similar problem running GoGlobal from a RHEL3 2.4.21 server. The socket down in /tmp/.gg-unix does not appear to be created and the client cannot connect. The problem seems to be related to how long it takes for the users .profile to be run. Users with short running .profiles can login while users with long running .profiles cannot.

Has a cause and solution to this problem been found and posted? Thanks.
ictest
Fresh Boarder
Posts: 3
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#2492
Re: Can't display anything on Solaris server 9 Years, 8 Months ago Karma: 2
Both of these cases would probably be helped by upgrading to the most recent version of GO-Global for UNIX. In the first case, a race condition at session startup was corrected, and in the second case we've extended the timeout during the session startup to avoid cases like this.

Hope this helps,
Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#2493
Re: Can't display anything on Solaris server 9 Years, 8 Months ago Karma: 0
I am currently runing server version 2.2.4.925. What is the minumum version required to corect the problem. I will check with my IT department to find out which versions are available. Thanks.
ictest
Fresh Boarder
Posts: 3
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#2494
Re: Can't display anything on Solaris server 9 Years, 8 Months ago Karma: 2
It looks like v2.2.4.878 was where we extended the session startup timeout, so you probably have that change already. The timeout was set to 30 seconds -- do your users' profiles take more than 30 seconds to execute?

Thanks,
Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#2499
Re: Can't display anything on Solaris server 9 Years, 8 Months ago Karma: 0
Hello Troy,
I do not believe that the profile takes more than 30 secondes. But I will run some timing experiments. if I shorten the users .profile the user can login. However, the profile looks like our standard profile. I do not see any modifications.

The log files says "Unable to connect to /tmp/.gg-unix/GG9" any idea why the socket is late or doesnt showup at all. I have noticed in some cases that the previous socket shows up during the next connection attempt. I mean that GG8 finaly shows up when the log files states that it was looking for GG9. Can I make the timeout longer than 30 seconds? Thanks.

Jerome
ictest
Fresh Boarder
Posts: 3
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl