Welcome, Guest
Please Login or Register.    Lost Password?

multiple Xgo processes
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: multiple Xgo processes
#1390
multiple Xgo processes 11 Years, 4 Months ago Karma: 0
I have 1 user opening a Linux desktop session, but I see 10 Xgo processes running. Also, this user is complaining about not being able to suspend/resume sessions. Any ideas on how to solve this?

Thanks,

Moshe
mlinzer
Fresh Boarder
Posts: 13
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#1394
Re: multiple Xgo processes 11 Years, 4 Months ago Karma: 2
Our Xgo process is multi-threaded. On linux, the multiple threads appear to be multiple processes, but in reality they are not. Newer linuxes use a different threading model that eliminates this.

Regarding the suspend/resume issues, I don't really have anything to go on here. I'd recommend upgrading to the most recent release, and if the problems continue, that you send the session logs to <A href="mailto:support@graphon.com">support @ graphon.com</a> for further review.

Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#1406
Re: multiple Xgo processes 11 Years, 4 Months ago Karma: 0
Sorry for being vague. I reviewed the logs and it looks like the suspended sessions are being closed after exactly 1 hour. Here are the entries from the gold.log.

[12 Jul 11:56:43 (I)] login: new process 23725 (session manager)
[12 Jul 11:56:43 (I)] auth: waiting for credentials from client
[12 Jul 11:56:43 (I)] timezone not found, using ''
[12 Jul 11:56:43 (I)] auth: trying method 'shadow'
[12 Jul 11:56:43 (W)] shadow: no shadow entry for user 'yuvk'
[12 Jul 11:56:43 (I)] auth: trying method 'passwd'
[12 Jul 11:56:43 (I)] passwd: successful login for user 'yuvk'
[12 Jul 11:57:03 (I)] license: checkout User: 'yuvk' App: 'goglobalux' clientId:
'10.191.21.109'
[12 Jul 11:57:03 (I)] session: start 'X:3' for user 'yuvk'
[12 Jul 11:57:03 (I)] session: running 'startXgo.sh --serverOpts -screen 0 0x0x0
-tune -singledepth -rootdepth 0 -mousedowninterval 40 -mouseupinterval 150 -dpi
75 -cachesize 16384 -cachecompressionthreshold 64 --clientCommand /usr/bin/sta
rtkde' on display 3(new display)
[12 Jul 11:57:03 (I)] session: new process 24100
[12 Jul 11:57:03 (I)] session: started user yuvk, instance 24100, display 3
[12 Jul 11:57:19 (I)] session: ended user yuvk, instance 24100, display 3
[12 Jul 11:57:19 (I)] session: server shutdown user yuvk, instance 24100, displa
y 3
[12 Jul 11:57:20 (I)] license: checkout User: 'yuvk' App: 'goglobalux' clientId:
'10.191.21.109'
[12 Jul 11:57:20 (I)] session: start 'X:4' for user 'yuvk'
[12 Jul 11:57:20 (I)] session: running 'startXgo.sh --serverOpts -screen 0 0x0x0
-tune -singledepth -rootdepth 0 -mousedowninterval 40 -mouseupinterval 150 -dpi
75 -cachesize 16384 -cachecompressionthreshold 64 --clientCommand /usr/bin/gno
me-session' on display 4(new display)
[12 Jul 11:57:20 (I)] session: new process 24471
[12 Jul 11:57:21 (I)] session: started user yuvk, instance 24471, display 4
[12 Jul 11:57:38 (E)] session: no response from client in 80.00 seconds, assumin
g the client closed connection.
[12 Jul 11:57:38 (I)] session: session manager (pid=27313) detected client conne
ction closed
[12 Jul 11:57:38 (I)] session: suspend on client exit, user yuvk, instance 27685
, display 1
[12 Jul 11:57:38 (I)] logout: process 27313 (session manager)
[12 Jul 12:57:41 (I)] Removing suspended entry pid=27685

This did not happen when we first started using the product. I have not changed any default flags for gold, and gold.conf is empty. What do I need to set so that suspended sessions are never removed, or removed after 48 hours?

About the linux issue, I am running on redhat enterprise WS 3.

Thanks,

Moshe
mlinzer
Fresh Boarder
Posts: 13
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#1412
Re: multiple Xgo processes 11 Years, 4 Months ago Karma: 2
Moshe,

You can use the following arguments to gold to configure the behaviour that you are looking for:
    [li]-max_suspended_age &lt;minutes&gt;
    This will set the maximum time a session can be suspended. Set to -1 for infinite, or 0 to not suspend sessions when clients are disconnected.

Another option that you might find useful is:
    [li]-no_ping
    This will prevent gold from deciding that the client has disconnected because it hasn't received a response. Sometime intermittant network problems can trigger this auto-suspend functionality, and disabling the pings can prevent this.

Hope this helps,
Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#1414
Re: multiple Xgo processes 11 Years, 4 Months ago Karma: 0
Thanks very much for the info! The max_suspended_age option seems to work. One last question: The admin guide mentions another option - clear_suspended. What is this option used for?

Thanks,

Moshe
mlinzer
Fresh Boarder
Posts: 13
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl