Welcome, Guest
Please Login or Register.    Lost Password?
Go to bottomPage: 1
TOPIC: Licensing error
#1351
Licensing error 11 Years, 5 Months ago Karma: 0
Hi I am having a problem with my UNIX server Goglobal installation.

I am testing out GoGlobal and using the demo license on one server. On this machine, I put the license into the directory as instructed but when i try and load up goglobal from the server i can log in fine with "root" user but any other user says "license unavailable(CDE)"

Is there another configuration that i need to do or something i'm doing wrong.

Also I have another server with a full goglobal license but when i try and load a goglobal session on that it appears then quickly disappears.

The logs for the 2nd server are below:

Gold.log:

Code:

dounem4#more gold.log
[25 May 14:39:47 (I)] Log opened.
[25 May 14:39:47 (I)] startup: enabling default authentication methods
[25 May 14:39:47 (I)] startup: connecting to database
[25 May 14:39:47 (I)] startup: testing for valid licensing
[25 May 14:39:47 (I)] startup: in progress
[25 May 14:39:47 (D)] startup: accepting connections on ports 491(tcp) and 791(ssl)
[25 May 14:39:47 (I)] startup: using standard encryption
[25 May 14:39:47 (I)] startup: using standard encryption
[25 May 14:39:52 (I)] login: new process 5962 (session manager)
[25 May 14:39:52 (I)] auth: waiting for credentials from client
[25 May 14:39:52 (I)] locale not found, using 'C'
[25 May 14:39:52 (I)] auth: trying method 'shadow'
[25 May 14:39:52 (W)] shadow: no shadow entry for user 'gostart'
[25 May 14:39:52 (I)] auth: trying method 'passwd'
[25 May 14:39:52 (I)] passwd: successful login for user 'gostart'
[25 May 14:39:52 (I)] license: checkout User: 'gostart' App: 'goglobalux' clientId: '10.147.16.199'
[25 May 14:39:52 (I)] session: start 'X:1' for user 'gostart'
[25 May 14:39:52 (I)] session: running 'startXDM.sh --serverOpts -query etnawsp11 -screen 0 1024x768x24 -rootdepth 0 -noclientba
ckbuf -bs -nobackingstore -ignoreobscurity -mousedowninterval 40 -mouseupinterval 150 -dpi 100 -cachesize 16384 -cachecompressio
nthreshold 64 -ac --clientCommand Disabled in XDM modes' on display 1(new display)
[25 May 14:39:52 (I)] session: new process 5967
[25 May 14:39:53 (I)] session: started user gostart, instance 5967, display 1
[25 May 14:39:54 (I)] session: ended user gostart, instance 5967, display 1
[25 May 14:39:54 (I)] session: server shutdown user gostart, instance 5967, display 1
[25 May 15:40:13 (I)] session: session manager (pid=5962) detected client connection closed
[25 May 15:40:13 (I)] logout: process 5962 (session manager)
[25 May 15:40:15 (I)] login: new process 8704 (session manager)
[25 May 15:40:15 (I)] auth: waiting for credentials from client
[25 May 15:40:15 (I)] locale not found, using 'C'
[25 May 15:40:16 (I)] auth: trying method 'shadow'
[25 May 15:40:16 (W)] shadow: no shadow entry for user 'gostart'
[25 May 15:40:16 (I)] auth: trying method 'passwd'
[25 May 15:40:16 (I)] passwd: successful login for user 'gostart'
[25 May 15:40:17 (I)] session: session manager (pid=8704) detected client connection closed
[29 May 14:31:09 (I)] login: new process 4656 (session manager)
[29 May 14:31:09 (I)] auth: waiting for credentials from client
[29 May 14:31:09 (I)] locale not found, using 'C'
[29 May 14:31:11 (I)] auth: trying method 'shadow'
[29 May 14:31:11 (W)] shadow: no shadow entry for user 'gostart'
[29 May 14:31:11 (I)] auth: trying method 'passwd'
[29 May 14:31:11 (I)] passwd: successful login for user 'gostart'
[29 May 14:31:13 (I)] license: checkout User: 'gostart' App: 'goglobalux' clientId: '10.147.1.199'
[29 May 14:31:13 (I)] session: start 'X:1' for user 'gostart'
[29 May 14:31:13 (I)] session: running 'startXDM.sh --serverOpts -query etnawsp11 -screen 0 1024x768x24 -rootdepth 0 -noclientba
ckbuf -bs -nobackingstore -ignoreobscurity -mousedowninterval 40 -mouseupinterval 150 -dpi 100 -cachesize 16384 -cachecompressio
nthreshold 64 -ac --clientCommand Disabled in XDM modes' on display 1(new display)
[29 May 14:31:13 (I)] session: new process 4664
[29 May 14:31:13 (I)] session: started user gostart, instance 4664, display 1
[29 May 14:31:14 (I)] session: ended user gostart, instance 4664, display 1
[29 May 14:31:14 (I)] session: server shutdown user gostart, instance 4664, display 1
[29 May 14:34:01 (I)] session: session manager (pid=4656) detected client connection closed
[29 May 14:34:01 (I)] logout: process 4656 (session manager)



gdbi Log

Code:


dounem4#more gdbi.log
postmaster successfully started
LOG:  database system was shut down at 2006-05-25 13:39:31 GMT
LOG:  checkpoint record is at 0/9919C0
LOG:  redo record is at 0/9919C0; undo record is at 0/0; shutdown TRUE
LOG:  next transaction ID: 3376; next OID: 17003
LOG:  database system is ready
info: executing '/opt/graphon/postgresql/bin/pg_ctl -D /opt/graphon/postgresql/data -o '-i -p 4491 -N 16 -B 33 ' start'
info: returned exit code 0
info: attempting database connection 0

arnie_ahu1
Fresh Boarder
Posts: 1
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#1352
Re: Licensing error 11 Years, 5 Months ago Karma: 2
Arnie,

The problem you're describing on the first server is usually caused by the license.dat file not being world-readable. Thus, root can read it (and obtain a license) but normal users cannot. Usually chmod'ing the license.dat to have 0755 permissions fixes this.

On the second server, it looks like the session is launching (from gold's perspective) correctly. Could you check for problems in the session logs (in ${HOME}/.graphon/session-logs/)? Usually problems like this have something to do with your .profile/.cshrc/.login/etc. files.

Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl