Welcome, Guest
Please Login or Register.    Lost Password?

Graphon does not start at boot on SuSE ES 9.0
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: Graphon does not start at boot on SuSE ES 9.0
#1030
Graphon does not start at boot on SuSE ES 9.0 12 Years, 1 Month ago Karma: 0
I have installed version 2.1.5 on my SuSE server, but it does not start automatically on boot.

There is a link under /etc/init.d/rc5.d/S07goglobalux that points to ../goglobalux, that in turn is a link to /usr/local/graphon/etc/goglobalux.

During boot, the script /etc/init.d/rc5.d/S07goglobalux is run, but Graphon does not start. Trying to run the same script manually does not start Graphon. However, if i run the script /etc/init.d/goglobalux, it works...
stig
Fresh Boarder
Posts: 6
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#1037
Re: Graphon does not start at boot on SuSE ES 9.0 12 Years, 1 Month ago Karma: 6
Stig,

You might want to play with the SuSE runlevel editor and add the GOGlobalux service if it doesn't already exist. You can use YaST and the command-line tool 'insserv' for this purpose.

-Erik
Erikt
Administrator
Posts: 591
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#1083
Re: Graphon does not start at boot on SuSE ES 9.0 12 Years ago Karma: 0
The SuSE runlevel editor does not help. Whatever I do, GoGlobalUX does not start at boot. A little investigation of the start script shows, that script names that starts with S or K, followed by a two-digit number, such as S07goglobalux is not allowed to start. There is a specific test for this within the script.

Why is there a test for this? The start script in SuSE IS S07goglobalux, so GoGlobalUX is not allowed to run in SuSE?
stig
Fresh Boarder
Posts: 6
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#1086
Re: Graphon does not start at boot on SuSE ES 9.0 12 Years ago Karma: 2
Stig,

Where do you see this test, exactly?

Thanks,
Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#1087
Re: Graphon does not start at boot on SuSE ES 9.0 12 Years ago Karma: 0
This is the part of the script i mean:

Code:


base=${0##*/}
link=${base#*[SK][0-9][0-9]}
test $link = $base && START_GOGLOBAL=yes
test "$START_GOGLOBAL" = yes || exit 0



In SuSE there are symbolic links:
/etc/rc.d/rc5.d/S07goglobalux -> ../goglobalux
/etc/rc.d/goglobalux -> /usr/local/graphon/etc/goglobalux

In the code above variables get the following values:
base=S07goglobalux
link=goglobalux

And because $link is not equal to $base, goglobalux does not start
stig
Fresh Boarder
Posts: 6
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl