Welcome, Guest
Please Login or Register.    Lost Password?

Unrecognised timezone - Graphon fails to start
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: Unrecognised timezone - Graphon fails to start
#1018
Unrecognised timezone - Graphon fails to start 12 Years, 1 Month ago Karma: 0
Hi,
My system has the following timezone set TZ=OPTUSGMT+0 and graphon will not start.
The log indicates the following error...

LOG: unrecognized time zone name: "OPTUSGMT+0"
FATAL: invalid value for parameter "timezone": "OPTUSGMT+0"

What is the correct format to specify a customised timezone in HP-UX that will allow graphon to start,
Thanks
Ian
ijessurun
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#1019
Re: Unrecognised timezone - Graphon fails to start 12 Years, 1 Month ago Karma: 2
Ian,

The easiest thing to do is just add it to the ${GOGLOBAL_ROOT}/etc/goglobalux startup script, something like:

Code:


TZ=GMT0
export TZ



This will be reset for users who log in, so it only affects the database and gold daemons, which don't use the timezone information.

HP appears to support some "odd" timezones that PostgreSQL doesn't understand. Yours is probably one of them.

Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
#1020
Re: Unrecognised timezone - Graphon fails to start 12 Years, 1 Month ago Karma: 0
Hi troy,
I tried what you suggested and got the same error.
I have found that by changing the timezone to TZ=UTC+0 the problem is fixed.
However if I use TZ=UTC0 then once again I get the unrecognised timezone.
Is there another way to have user specific timezones accepted by graphon and the PostgreSQL,
Thanks
Ian
ijessurun
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#1021
Re: Unrecognised timezone - Graphon fails to start 12 Years, 1 Month ago Karma: 2
Hello Ian,

In the short term, setting the timezone manually from the script to something that is accepted is probably the best solution. In the long term, we are discontinuing the use of PostgreSQL in future releases of GO-Global for UNIX, so this problem will not exist in the future releases.

Troy
troy
Administrator
Posts: 231
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Birthday: 01/14
The administrator has disabled public write access.
 
Go to topPage: 1
Moderators: troy, Andyl